Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Server Availability Dropped
Investigating
·
Partial outage
Resovled.
Tue, Apr 21, 2026, 06:58 AM
(
1
month ago)
·
View all updates
Affected components
Apr 21, 2026, 06:39 AM
Now
Vozo Web App
Features
3 affected components
Updates
Investigating
Resovled.
Tue, Apr 21, 2026, 06:58 AM
Investigating
Creating new projects might failed due to internal error.
Tue, Apr 21, 2026, 06:39 AM
(
19
minutes earlier)
Server Availability Dropped - Vozo Status